< 文章详情

KB3042553补丁提示不能安装的解决办法

2019/8/20 326次
windows server 2012 R2 Standard x64 安装KB3042553补丁,报出 “此更新不适用于您的计算机”。
通常情况下,以下情况可能会出现更新不适用的报错信息:
1. 缺少必要更新。
根据“MS15-034:HTTP.sys 中的漏洞可能允许远程执行代码:2015 年 4 月 14 日”中的描述,提示WS 2012 R2安装KB3042553 需要先决\必要更新 KB2919355:
https://support.microsoft.com/zh-cn/help/3042553/ms15-034-vulnerability-in-http-sys-could-allow-remote-code-execution-a

KB 2919355:
https://support.microsoft.com/zh-cn/help/2919355/windows-rt-8-1--windows-8-1--and-windows-server-2012-r2-update-april-2

2. 已经安装了取代更新。
可以在 Windows Update Catalog 网站查询到 KB3042553 的具体信息,包括取代更新。打开以下链接,单击“Windows Server 2012 R2安全更新程序(KB3042553)“,打开”Package Details“标签,可以查看替代更新:
https://www.catalog.update.microsoft.com/Search.aspx?q=3042553

3. 已经安装了该更新。
通过以下PowerShell命令列出已安装的更新:
Get-hotfix

然后确认该更新,或者其替换更新是否已经安装。

4. 下载的更新安装包不适用于当前系统。
请访问以下链接,重新下载并安装 KB3042553 – 选择适用于系统的语言版本,然后单击下载:
https://www.microsoft.com/en-us/download/details.aspx?id=46500